<!DOCTYPE html>
<html style="margin:0px!important;">
<head>
<meta name="viewport" content="width=device-width,maximum-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes">
<link rel="Shortcut Icon" href="/wp-content/uploads/2016/08/cropped-12960014_1718391878430811_1888287782_a.jpg" type="image/x-icon" />
<title>The State Hornet | ‘Do I look more dangerous than a white man?’: Sac State athletes speak on social justice issues</title>

<script type="text/javascript">
	var trackcmp_email = '';
	var trackcmp = document.createElement("script");
	trackcmp.async = true;
	trackcmp.type = 'text/javascript';
	trackcmp.src = '//trackcmp.net/visit?actid=475409147&e='+encodeURIComponent(trackcmp_email)+'&r='+encodeURIComponent(document.referrer)+'&u='+encodeURIComponent(window.location.href);
	var trackcmp_s = document.getElementsByTagName("script");
	if (trackcmp_s.length) {
		trackcmp_s[0].parentNode.appendChild(trackcmp);
	} else {
		var trackcmp_h = document.getElementsByTagName("head");
		trackcmp_h.length && trackcmp_h[0].appendChild(trackcmp);
	}
</script>







<title>‘Do I look more dangerous than a white man?’: Sac State athletes speak on social justice issues - The State Hornet</title>
<meta name="description" content="Sacramento State athletes have joined professionals such as Naomi Osaka and LeBron James in initiating the conversation about social justice.With the pandemic forcing courses to be held virtually this year and the NCAA giving every athlete another year of eligibility whether they have a season in the spring or not,&hellip;" />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://statehornet.com/2020/09/sac-state-athletes-social-justice/" />
<meta name="author" content=" Estefany Nuñez">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="‘Do I look more dangerous than a white man?’: Sac State athletes speak on social justice issues - The State Hornet" />
<meta name="twitter:description" content="Sacramento State athletes have joined professionals such as Naomi Osaka and LeBron James in initiating the conversation about social justice.With the pandemic forcing courses to be held virtually this year and the NCAA giving every athlete another year of eligibility whether they have a season in the spring or not,&hellip;" />
<meta name="twitter:image:src" content="https://statehornet.com/wp-content/uploads/2020/09/FEATUREDPERFECT-900x599.jpg" />
<link rel="alternate" type="application/rss+xml" title="The State Hornet &raquo; ‘Do I look more dangerous than a white man?’: Sac State athletes speak on social justice issues Comments Feed" href="https://statehornet.com/2020/09/sac-state-athletes-social-justice/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/statehornet.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='farbtastic-css'  href='https://statehornet.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://statehornet.com/wp-includes/css/dashicons.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://statehornet.com/wp-includes/js/thickbox/thickbox.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://statehornet.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://statehornet.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://statehornet.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://statehornet.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://statehornet.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='activecampaign-form-block-css'  href='https://statehornet.com/wp-content/plugins/activecampaign-subscription-forms/activecampaign-form-block/build/style-index.css?ver=1600074267' type='text/css' media='all' />
<link rel='stylesheet' id='nk-awb-css'  href='https://statehornet.com/wp-content/plugins/advanced-backgrounds/assets/awb/awb.min.css?ver=1.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://statehornet.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.11' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-layout-66333-css'  href='https://statehornet.com/wp-content/uploads/bb-plugin/cache/66333-layout.css?ver=f83d711a77fb438714219ac6c7e610d5' type='text/css' media='all' />
<link rel='stylesheet' id='fvp-frontend-css'  href='https://statehornet.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-video-popup-css'  href='https://statehornet.com/wp-content/plugins/responsive-youtube-vimeo-popup/assets/css/wp-video-popup.css?ver=2.8' type='text/css' media='all' />
<link rel='stylesheet' id='timeline_grid_style-css'  href='https://statehornet.com/wp-content/plugins/timeline-grid//assets/frontend/css/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='owl.carousel-css'  href='https://statehornet.com/wp-content/plugins/timeline-grid/assets/frontend/css/owl.carousel.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='owl.theme-css'  href='https://statehornet.com/wp-content/plugins/timeline-grid/assets/frontend/css/owl.theme.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-woocommerce-css'  href='https://statehornet.com/wp-content/plugins/timeline-grid/assets/frontend/css/style-woocommerce.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css'  href='https://statehornet.com/wp-content/plugins/timeline-grid/assets/frontend/css/animate.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='style.skins-css'  href='https://statehornet.com/wp-content/plugins/timeline-grid/assets/global/css/style.skins.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='style.layout-css'  href='https://statehornet.com/wp-content/plugins/timeline-grid/assets/global/css/style.layout.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://statehornet.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%2C700%2C600%7CAnton%3A400%2C700%7CFjalla+One%3A400%2C800%2C700%7CChivo%3A400%2C700&#038;display=swap&#038;ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://statehornet.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://statehornet.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://statehornet.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://statehornet.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://statehornet.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://statehornet.com/wp-content/themes/snoflex/style.css?ver=20200915' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-css'  href='https://statehornet.com/wp-content/plugins/newsletter/style.css?ver=6.8.7' type='text/css' media='all' />
<link rel='stylesheet' id='dry_awp_theme_style-css'  href='https://statehornet.com/wp-content/plugins/advanced-wp-columns/assets/css/awp-columns.css?ver=5.5.1' type='text/css' media='all' />
<style id='dry_awp_theme_style-inline-css' type='text/css'>
@media screen and (max-width: 1024px) {	.csColumn {		clear: both !important;		float: none !important;		text-align: center !important;		margin-left:  10% !important;		margin-right: 10% !important;		width: 80% !important;	}	.csColumnGap {		display: none !important;	}}
</style>
<link rel='stylesheet' id='snoadrotate-default-css-css'  href='https://statehornet.com/wp-content/plugins/sno-ad-rotate/css/widget-default.css?ver=1.0' type='text/css' media='screen' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://statehornet.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js?ver=master-2015-08' id='jquery.fitvids-js'></script>
<script type='text/javascript' id='fvp-frontend-js-extra'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"https:\/\/statehornet.com\/wp-admin\/admin-ajax.php","nonce":"ae42ce7d5c","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/featured-video-plus/js/frontend.min.js?ver=2.3.3' id='fvp-frontend-js'></script>
<script type='text/javascript' id='timeline_grid_scripts-js-extra'>
/* <![CDATA[ */
var timeline_grid_ajax = {"timeline_grid_ajaxurl":"https:\/\/statehornet.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/timeline-grid/assets/frontend/js/scripts.js?ver=5.5.1' id='timeline_grid_scripts-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/timeline-grid/assets/frontend/js/masonry.pkgd.min.js?ver=5.5.1' id='masonry.pkgd.min-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/timeline-grid/assets/frontend/js/owl.carousel.js?ver=5.5.1' id='owl.carousel-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.5.1' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.5.1' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20200802' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20200803' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20200803' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.5.1' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.5.1' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.5.1' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.5.1' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/statehornet.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20200702' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.5.1' id='flex-parallax-js'></script>
<link rel="https://api.w.org/" href="https://statehornet.com/wp-json/" /><link rel="alternate" type="application/json" href="https://statehornet.com/wp-json/wp/v2/posts/66333" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://statehornet.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://statehornet.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='VIDEO: The WELL opens with outdoor fitness options by reservation' href='https://statehornet.com/2020/09/sac-state-well-opens-outdoor/' />
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://statehornet.com/?p=66333' />
<link rel="alternate" type="application/json+oembed" href="https://statehornet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstatehornet.com%2F2020%2F09%2Fsac-state-athletes-social-justice%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://statehornet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fstatehornet.com%2F2020%2F09%2Fsac-state-athletes-social-justice%2F&#038;format=xml" />
<script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script><script type="text/javascript">require(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us18.list-manage.com","uuid":"80495e1db18e0309dc9e73d14","lid":"879a41dada"}) })</script><style type="text/css">#at_preview .preview_footer {
                background: #fcfcfc !important;
                font-size: 70% !important;
            }
            #at_preview .preview_footer a,#at_preview .preview_footer {
                text-decoration: none !important;
                text-transform: uppercase !important;
            }</style>

<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="‘Do I look more dangerous than a white man?’: Sac State athletes speak on social justice issues" />
<meta property="og:type" content="article" />
<meta name="author" content="Estefany Nuñez" />
<meta property="og:url" content="https://statehornet.com/2020/09/sac-state-athletes-social-justice/" />
<meta property="og:image" content="https://statehornet.com/wp-content/uploads/2020/09/FEATUREDPERFECT-900x599.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="599" />
	<meta property="og:site_name" content="The State Hornet" />
	<meta property="og:description" content="Many Sac State athletes are choosing to speak out on issues of racial inequality, joining professionals such as Naomi Osaka and LeBron James in initiating the conversation about social justice." />
	<meta name="description" content="Many Sac State athletes are choosing to speak out on issues of racial inequality, joining professionals such as Naomi Osaka and LeBron James in initiating the conversation about social justice." />
	<meta property="article:section" content="Featured" />
	<meta property="article:tag" content="" />
<!-- End of Open Graph Meta Tags -->


<!-- Facebook Open Graph protocol plugin NEEDS an admin or app ID to work, please visit the plugin settings page! -->
<link rel="icon" href="https://statehornet.com/wp-content/uploads/2016/08/cropped-12960014_1718391878430811_1888287782_a-70x70.jpg" sizes="32x32" />
<link rel="icon" href="https://statehornet.com/wp-content/uploads/2016/08/cropped-12960014_1718391878430811_1888287782_a-475x475.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://statehornet.com/wp-content/uploads/2016/08/cropped-12960014_1718391878430811_1888287782_a-475x475.jpg" />
<meta name="msapplication-TileImage" content="https://statehornet.com/wp-content/uploads/2016/08/cropped-12960014_1718391878430811_1888287782_a-475x475.jpg" />








<style type="text/css" media="screen">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</style></head>
<body data-rsssl=1>


<div id="lf_wrap">
<div id='snopostid-66333' class='snopostid'>
<div id="sno_longform" class="sno-story-66333">
	
						<style type="text/css">
				#sno_longform #mainbody, #sno_longform #commentsbody, #sno_longform #commentsbox, #sno_longform .commentblock li, #sno_longform .widgetbody, #sno_longform .titlewrap, #sno_longform .commenttext { background: #000000 !important; }
				#sno_longform a { color: #00AA4F !important; }
				#sno_longform #storypage h1, #sno_longform p, #sno_longform h5, #sno_longform .relateddivider, #sno_longform .photocaption, #sno_longform .storydeck p, #sno_longform #commentblock  { color: #ffffff !important; }
				#sno_longform .background-gray, #sno_longform .background-white { background: #000000 !important; }
				#sno_longform .largequote { text-shadow: none;}
				#sno_longform .storyshadow { box-shadow: none !important; }
				#sno_longform .dividinglinedeck, #sno_longform .dividingline { border-color: #ffffff !important; }
				#sno_longform #storypage .wp-caption, #sno_longform #storypage p.wp-caption-text, .lf-immersive-caption { background: #000000 !important; color: #ffffff !important; }
				</style>
			<style>
				#wpadminbar {display:none!important;}
			</style><div class='header'><div class="altheader-menu"><div id="hover-menu"><div class="sno-menu menu-icon dashicons dashicons-menu"></div><div class="sno-menu close-icon foundation-icons fi-x" style="display:none;"></div></div></div><div class="lf_headerleft"><a href="/"><img src="https://statehornet.com/wp-content/uploads/2017/10/State-Hornet-logo.jpg" alt="The student news site of Sacramento State University" /></a></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="66333"><a class='commentscroll' href='https://statehornet.com/2020/09/sac-state-athletes-social-justice/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fstatehornet.com%2F2020%2F09%2Fsac-state-athletes-social-justice%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=‘Do I look more dangerous than a white man?’: Sac State athletes speak on social justice issues&amp;url=https%3A%2F%2Fstatehornet.com%2F%3Fp%3D66333" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//statehornet.com/2020/09/sac-state-athletes-social-justice/?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"></div></a></div></div>
<div id="storypage">
<div id="altheader-searchbox"><ul class="slidemenu mobile-menu"><li class="mobile-search" style="margin-top: 0px; clear: both;"><form method="get" id="searchform-alt" action="https://statehornet.com/">
									<label for="s" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
								</form></li><div class="mobile-menu"><ul id="menu-mobile-menu" class="menu"><li id="menu-item-63177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63177"><a href="https://statehornet.com/category/news/">News</a></li>
<li id="menu-item-63178" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-63178"><a href="https://statehornet.com/category/sports/">Sports</a></li>
<li id="menu-item-63179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63179"><a href="https://statehornet.com/category/ae/">Arts &#038; Entertainment</a></li>
<li id="menu-item-63180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63180"><a href="https://statehornet.com/category/features/">Features</a></li>
<li id="menu-item-63181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63181"><a href="https://statehornet.com/category/opinion/">Opinion</a></li>
<li id="menu-item-63182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63182"><a href="https://statehornet.com/category/multimedia/">Multimedia</a></li>
<li id="menu-item-63183" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63183"><a href="https://statehornet.com/tips-and-suggestions/">Contact Us</a></li>
<li id="menu-item-63184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63184"><a href="https://us18.campaign-archive.com/home/?u=80495e1db18e0309dc9e73d14&#038;id=879a41dada">Newsletters</a></li>
</ul></div></ul></div><div id="mainbody" style="padding-top:70px;"><div class="content main"><div class="photowrap"><a class='modal-photo photooverlay' data-story-id='66333' data-photo-id='66396' href='#photo'><img src='https://statehornet.com/wp-content/uploads/2020/09/FEATUREDPERFECT-900x599.jpg' alt='Athletes+from+the+Sac+State+basketball%2C+football+and+volleyball+teams+speak+about+the+Black+Lives+Matter+movement%2C+social+justice+and+police+harassment.+' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photo photo-enlarge elusive el-icon-zoom-in' data-story-id='66333' data-photo-id='66396'></div></div><p class="photocredit">Photos courtesy of Macey Haydenn, Elijah Dotson and Brandon Davis.</p><p class="photocaption">Athletes from the Sac State basketball, football and volleyball teams speak about the Black Lives Matter movement, social justice and police harassment. </p><h1 id="storyheadline" class="storyheadline">‘Do I look more dangerous than a white man?’: Sac State athletes speak on social justice issues</h1><div class="dividingline storystart"></div><p class="byline"> Estefany Nuñez</p><p class="longdate"><span class="time-wrapper">September 29, 2020</span></p><div class="leftside storybody"><span class="storycontent"><div class="fl-builder-content fl-builder-content-66333 fl-builder-content-primary fl-builder-global-templates-locked" data-post-id="66333"><div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5f72d01f026fa" data-node="5f72d01f026fa">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f72d01f0bd88" data-node="5f72d01f0bd88">
			<div class="fl-col fl-node-5f72d01f0be35" data-node="5f72d01f0be35">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f72b1b89082c" data-node="5f72b1b89082c">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>Sacramento State athletes have joined professionals such as Naomi Osaka and LeBron James in initiating the conversation about social justice.<br />
With the pandemic forcing courses to be held virtually this year and the NCAA giving every athlete another year of eligibility whether they have a season in the spring or not, some students have chosen to focus on social justice during this time.<br />
Senior volleyball player Macey Haydenn said she has been taking advantage of social media platforms in her free time by spreading educational information about social justice and the Black Lives Matter movement.<br />
“It didn’t start this year,” Haydenn said. “All this stuff didn’t start this year — this has been going on since Black people were in slavery.”<br />
Haydenn said she appreciates the opportunity to be able to speak out and refine her voice on subjects that matter to her. In the last few months, she said she has been recognizing a more frequent pattern of ignorance in people close to her.<br />
Haydenn said people swipe up on her Instagram posts about social justice to vehemently disagree with her, but this does not bother her because she believes and respects that everyone has an opinion.<br />
<em>Story continues below Instagram post.</em></p>
</div>
	</div>
</div>
<div class="fl-module fl-module-html fl-node-5f72b52b948b2" data-node="5f72b52b948b2">
	<div class="fl-module-content fl-node-content">
		<div class="fl-html">
	<div align="center">
    <blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CFkgd9JMyHV/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CFkgd9JMyHV/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> <div style=" display: flex; flex-direction: row; align-items: center;"> <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div> <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"> <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div> <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div> <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"> <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div> <div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"> <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div> <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div> <div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a> <p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CFkgd9JMyHV/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Black Lives Matter. Yesterday. Today. Tomorrow. Always</a></p> <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/maceyhaydenn/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Mace</a> (@maceyhaydenn) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-09-25T18:58:49+00:00">Sep 25, 2020 at 11:58am PDT</time></p></div></blockquote> <script async src="//www.instagram.com/embed.js"></script>
</div></div>
	</div>
</div>
<div class="fl-module fl-module-rich-text fl-node-5f72b1caa8533" data-node="5f72b1caa8533">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>“My dad’s Black and my mom’s white, so I got a little bit of each side,” Haydenn said. “I got fear from the Black side, I got the talks about how to act when you get pulled over by the police and I do have my own type of privilege because I am light-skinned, where I’m not experiencing the same things as people who are darker than me.”<br />
<strong>RELATED: </strong><a href="https://statehornet.com/2020/09/jacob-blake-defunding-the-police/" rel="noopener" target="_blank"><strong>OPINION: Defunding the police is the only option left</strong></a><br />
Senior running back Elijah Dotson said being born and raised in Sacramento gave him the opportunity to see firsthand how his community protested in a way that wasn’t destructive, but instead demanded equality in the way it could.<br />
“For there to be a pandemic and then have wildfires and a social justice movement happen all at the same time, football seems very small right now — we do what we can,” Dotson said. “You never really expect something of this caliber.”<br />
Dotson said the Sacramento community is trying to create equality with the voices it has because people in Black and brown communities should not be living their lives like this.<br />
<strong>RELATED: </strong><a href="https://statehornet.com/2020/09/black-lives-matter-sacramento-county-protest-racial-injustice-defund-the-police/" rel="noopener" target="_blank"><strong>Demonstrations against racial injustice advance through greater Sacramento area</strong></a></p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-photo fl-node-5f73599ec0daf" data-node="5f73599ec0daf">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f73599ec0da3" data-node="5f73599ec0da3">
			<div class="fl-col fl-node-5f73599ec0da5 fl-col-has-cols" data-node="5f73599ec0da5">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-separator fl-node-5f73599ec0da7" data-node="5f73599ec0da7">
	<div class="fl-module-content fl-node-content">
		<div class="fl-separator"></div>
	</div>
</div>

<div class="fl-col-group fl-node-5f73599ec0da8 fl-col-group-nested" data-node="5f73599ec0da8">
			<div class="fl-col fl-node-5f73599ec0dac fl-col-small" data-node="5f73599ec0dac">
	<div class="fl-col-content fl-node-content">
		</div>
</div>
			<div class="fl-col fl-node-5f73599ec0dad" data-node="5f73599ec0dad">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f73599ec0dae fl-animation fl-fade-in" data-node="5f73599ec0dae" data-animation-delay="0" data-animation-duration="1">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>“There seems to be a standard for how to treat each race and if your skin is darker, it’s worse. Do I look more dangerous than a white man?”</p>
</div>
	</div>
</div>
<div class="fl-module fl-module-rich-text fl-node-5f735a464a157 fl-animation fl-fade-in" data-node="5f735a464a157" data-animation-delay="0.5" data-animation-duration="1">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>Elijah Dotson</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5f735d44cf5bb" data-node="5f735d44cf5bb">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f735d44e3870" data-node="5f735d44e3870">
			<div class="fl-col fl-node-5f735d44e396b" data-node="5f735d44e396b">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f7367cd5c845" data-node="5f7367cd5c845">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p><a href="https://statehornet.com/staff_profile/eucario-calderon/" rel="noopener" target="_blank">Eucario Calderon</a></p>
</div>
	</div>
</div>
<div class="fl-module fl-module-rich-text fl-node-5f735bfa4374b" data-node="5f735bfa4374b">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>Sac State senior running back Elijah Dotson lines up for a drill during training camp on Aug. 12, 2019 at the practice field. Dotson is a Sacramento native and says he wants social awareness and equality for his community.</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5f735ad4bffdb" data-node="5f735ad4bffdb">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f735ad4ccaf0" data-node="5f735ad4ccaf0">
			<div class="fl-col fl-node-5f735ad4ccb85" data-node="5f735ad4ccb85">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f72c03e40b02" data-node="5f72c03e40b02">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>“There seems to be a standard for how to treat each race and if your skin is darker, it’s worse,” Dotson said. “Do I look more dangerous than a white man?”<br />
Dotson said that despite race being a complicated and complex topic, he still thinks it is important to bring that consciousness and social awareness to conversations on campus.<br />
“When we say Black lives matter, we don’t mean that we’re the only lives that matter. We’re the only ones in trouble,” Dotson said.<br />
Sac State senior wide receiver Isaiah Gable said he has also been outspoken about the Black Lives Matter movement because it is personal to him.<br />
Gable recalled the story of how he and his friend were walking to a store when a police car drove by, turned around and stopped them. Once out of the car, the police officer instructed the boys to hold their hands up above their heads.<br />
“He just patted us down and was talking rowdy to us, for no reason,” Gable said.<br />
Even though Gable and his friend only had cellphones and money in their pockets, a second police car was called to assist the first police officer.<br />
“One of the guys started being rowdy with my friend, just police harassment,” Gable said. “And another had his hand on his gun the whole time, like we were about to do something.”<br />
Gable said the encounter felt horrible, and he thought it was ridiculous that he was targeted for the color of his skin.<br />
“As long as we keep fighting, we’re going to find justice,” Gable said.<br />
Gable said he is behind the new mandated requirement of an ethnic studies course for the California State University system. The football player himself is majoring in ethnic studies.<br />
<b>RELATED: </b><a href="https://statehornet.com/2020/09/ab-1460-ethnic-studies-requirement/" rel="noopener" target="_blank"><strong>New ethnic studies requirement signed into law by Gov. Newsom</strong></a></p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-photo fl-node-5f73698b3b82f" data-node="5f73698b3b82f">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f736a4405291" data-node="5f736a4405291">
			<div class="fl-col fl-node-5f73698b3baf2 fl-col-has-cols" data-node="5f73698b3baf2">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-separator fl-node-5f73698b3baf3" data-node="5f73698b3baf3">
	<div class="fl-module-content fl-node-content">
		<div class="fl-separator"></div>
	</div>
</div>

<div class="fl-col-group fl-node-5f736cac401ee fl-col-group-nested" data-node="5f736cac401ee">
			<div class="fl-col fl-node-5f73698b3baf5 fl-col-small" data-node="5f73698b3baf5">
	<div class="fl-col-content fl-node-content">
		</div>
</div>
			<div class="fl-col fl-node-5f73698b3baf6" data-node="5f73698b3baf6">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f73698b3baf7 fl-animation fl-fade-in" data-node="5f73698b3baf7" data-animation-delay="0" data-animation-duration="1">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>“Although it is tiring to have to explain the issues over and over, but for us — that misunderstanding is the barrier that needs to be broken.”</p>
</div>
	</div>
</div>
<div class="fl-module fl-module-rich-text fl-node-5f73698b3baf8 fl-animation fl-fade-in" data-node="5f73698b3baf8" data-animation-delay="0.5" data-animation-duration="1">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>Brandon Davis</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5f736b44552f8" data-node="5f736b44552f8">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f736b4455385" data-node="5f736b4455385">
			<div class="fl-col fl-node-5f736b4455387" data-node="5f736b4455387">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f736b4455388" data-node="5f736b4455388">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p><a href="https://statehornet.com/staff_profile/luis-platero/" rel="noopener" target="_blank">Luis Platero</a></p>
</div>
	</div>
</div>
<div class="fl-module fl-module-rich-text fl-node-5f736b4455389" data-node="5f736b4455389">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>Sac State senior guard Brandon Davis driving to the rim, getting by his defender at the Nest against Montana State on Thursday, Feb. 27. Davis says him and his teammates have come together and talked about racism and inequality.</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5f735ac16adb5" data-node="5f735ac16adb5">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f735ac17a4b9" data-node="5f735ac17a4b9">
			<div class="fl-col fl-node-5f72d056ee5d2 fl-col-has-cols" data-node="5f72d056ee5d2">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f72c0580c967" data-node="5f72c0580c967">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>Senior point guard Brandon Davis said the Sac State basketball team has been organizing Zoom calls to have a space to discuss what could be done as a team to combat racism and unlearn prejudices.<br />
“Although it is tiring to have to explain the issues over and over, but for us — that misunderstanding is the barrier that needs to be broken,” Davis said.<br />
<em>Story continues below tweet. </em></p>
</div>
	</div>
</div>
<div class="fl-module fl-module-html fl-node-5f72c0c894de2" data-node="5f72c0c894de2">
	<div class="fl-module-content fl-node-content">
		<div class="fl-html">
	<blockquote class="twitter-tweet" data-theme="dark"><p lang="en" dir="ltr"><a href="https://twitter.com/SacHornetsMBB?ref_src=twsrc%5Etfw">@SacHornetsMBB</a> is grateful for the ZOOM w/ Chris Young, General Counsel <a href="https://twitter.com/ironclad_inc?ref_src=twsrc%5Etfw">@ironclad_inc</a> who previously worked w/ the Obama Admin &amp; in the US Dept of Justice. Discussed Voting rights &amp; Voter Education <a href="https://twitter.com/hashtag/AllInForVoting?src=hash&amp;ref_src=twsrc%5Etfw">#AllInForVoting</a> <a href="https://t.co/3TTZdwkTVD">pic.twitter.com/3TTZdwkTVD</a></p>&mdash; Coach Laird (@bmlaird) <a href="https://twitter.com/bmlaird/status/1309198515118235654?ref_src=twsrc%5Etfw">September 24, 2020</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div>
	</div>
</div>
<div class="fl-module fl-module-rich-text fl-node-5f72c0d90d8a4" data-node="5f72c0d90d8a4">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>“I think it’s going to take a lot of patience, as we’ve been forced to show over years, centuries and decades against racism,” Davis said.<br />
Although senior forward Bryce Fowler from Sac State’s basketball team is white, he said he recognizes the importance of having white people also speak out against racism.<br />
“I’ve posted stuff on Twitter and Instagram and I’ve had a couple of family members unfollow me because they disagree with how I feel, so it’s opened my eyes even more,” Fowler said. “It’s just not right. I just don’t understand how someone can think that killing innocent Black people is okay and there to be no consequences for their actions.”<br />
Junior Samaad Hector said the Sac State basketball team has been trying its best to push through 2020 despite the global pandemic and current social political climate.</p>
</div>
	</div>
</div>

<div class="fl-col-group fl-node-5f734fdb299df fl-col-group-nested" data-node="5f734fdb299df">
			<div class="fl-col fl-node-5f72e91d74fdf" data-node="5f72e91d74fdf">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f72e88620e72 fl-animation fl-fade-in" data-node="5f72e88620e72" data-animation-delay="0" data-animation-duration="1">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p><em>“We shouldn’t be living like that, we’re always targeted. It doesn't matter what you look like. If you’re Black, you’re gonna be a target and that’s just not right, that needs to change.”</em></p>
</div>
	</div>
</div>
<div class="fl-module fl-module-rich-text fl-node-5f72e977e4788 fl-animation fl-fade-in" data-node="5f72e977e4788" data-animation-delay="0.5" data-animation-duration="1">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>Samaad Hector</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
<div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5f735aab1a2d3" data-node="5f735aab1a2d3">
	<div class="fl-row-content-wrap">
						<div class="fl-row-content fl-row-fixed-width fl-node-content">
		
<div class="fl-col-group fl-node-5f735aab26841" data-node="5f735aab26841">
			<div class="fl-col fl-node-5f735aab268e2" data-node="5f735aab268e2">
	<div class="fl-col-content fl-node-content">
	<div class="fl-module fl-module-rich-text fl-node-5f72e9e48cb1a" data-node="5f72e9e48cb1a">
	<div class="fl-module-content fl-node-content">
		<div class="fl-rich-text">
	<p>“As a Black man in America, I’m sick and tired of leaving my house afraid that I’m not going to return home, afraid that I’m not going to speak to my mom the next day, and that’s not how somebody should be living,” Hector said. “We shouldn’t be living like that, we’re always targeted. It doesn't matter what you look like. If you’re Black, you’re gonna be a target and that’s just not right, that needs to change.”<br />
The Sac State men’s basketball team is one of many athletic groups that registered every member of its team to vote in an attempt to get athletes prepared to participate in the upcoming 2020 presidential election.<br />
“President 45 is not helping us, he’s not on our side so it’s important to encourage everybody to vote because he’s not with us,” Hector said. “We need change.”</p>
</div>
	</div>
</div>
	</div>
</div>
	</div>
		</div>
	</div>
</div>
</div></span></div></div><div class="clear"></div><div id="content" class="content main"><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">
View our comment policy <a href="https://statehornet.com/state-hornet-comment-policy/">here</a><br /><br />





<form action="https://statehornet.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="66333" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div></div><div class="footerbar"><p><a href="https://statehornet.com">The State Hornet</a> &bull; Copyright 2020 &bull; <a href="http://snosites.com/why-sno/">FLEX WordPress Theme</a> by <a href="https://snosites.com">SNO</a> &bull; <a href="https://statehornet.com/wp-login.php">Log in</a></p></div>








		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-80186074-25', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/statehornet.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/advanced-backgrounds/assets/vendor/jarallax/jarallax.min.js?ver=1.12.4' id='jarallax-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/advanced-backgrounds/assets/vendor/jarallax/jarallax-video.min.js?ver=1.12.4' id='jarallax-video-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/advanced-backgrounds/assets/vendor/object-fit-images/ofi.min.js?ver=3.2.4' id='object-fit-images-js'></script>
<script type='text/javascript' id='nk-awb-js-extra'>
/* <![CDATA[ */
var AWBData = {"settings":{"disable_parallax":[],"disable_video":[],"full_width_fallback":true}};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/advanced-backgrounds/assets/awb/awb.min.js?ver=1.7.0' id='nk-awb-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.11' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' id='site_tracking-js-extra'>
/* <![CDATA[ */
var php_data = {"ac_settings":{"tracking_actid":475409147,"site_tracking_default":1,"site_tracking":1},"user_email":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/activecampaign-subscription-forms/site_tracking.js?ver=5.5.1' id='site_tracking-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/bb-plugin/js/jquery.waypoints.min.js?ver=2.3.2.7' id='jquery-waypoints-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/uploads/bb-plugin/cache/66333-layout.js?ver=f83d711a77fb438714219ac6c7e610d5' id='fl-builder-layout-66333-js'></script>
<script type='text/javascript' id='qppr_frontend_scripts-js-extra'>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</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.2.0' id='qppr_frontend_scripts-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/responsive-youtube-vimeo-popup/assets/js/wp-video-popup.js?ver=2.8' id='wp-video-popup-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/statehornet.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5' id='wp-polls-js'></script>
<script type='text/javascript' id='newsletter-subscription-js-extra'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://statehornet.com/wp-content/plugins/newsletter/subscription/validate.js?ver=6.8.7' id='newsletter-subscription-js'></script>
<script type='text/javascript' src='https://statehornet.com/wp-includes/js/wp-embed.min.js?ver=5.5.1' id='wp-embed-js'></script>









   </div>

</div>
</div>
</div>
</div>
</body>

</html>